Inconsistent

Inconsistent

EA is inconsistent

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Addressing Entry Discrepancies In the event of discrepancies between your TradingView entries and MetaTrader's order records, please follow these steps for resolution:
  1. First, cross-check your TradingView's alerts log and the PineConnector Signals Log
  2. Once the logs above match, evaluate the Experts output which prints more information on how your signal is being processed by the EA.

It's important to note that the comparison should not be made solely between your TradingView chart and MetaTrader trade log as there is possibility of errors in your entry coding, misconfiguration of your alerts, or a combination of both factors.

This guide provides troubleshooting steps for the PineConnector EA when it processes your signals inconsistently. Below are some common issues and their possible causes:

Issues

  1. Target Type set to "price" is processed as "pips"
  2. Volume Type set to "percentage" is processed as "lots"
  3. Pyramiding set to "Off" still allows stacking of trades
  4. Other instances where signals are processed differently from the EA's settings.

Possible Cause

These inconsistencies may occur if you have multiple PineConnector EAs running simultaneously on your platform.

Solution

Ensure that you only have one PineConnector EA attached to each symbol and timeframe. Using multiple EAs with different settings can lead to inconsistencies and will not improve performance. A single PineConnector EA can execute commands on all symbols effectively.

By following these troubleshooting steps, you should be able to resolve issues related to inconsistent PineConnector EA behavior.

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One Instance per License ID For every unique License ID, you should only have 1 instance of the EA running.
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1 PineConnector EA, 100 Symbols You only need to run one instance of the EA, regardless of the chart or time frame you're using. By attaching the PineConnector EA to your MetaTrader terminal, you gain access to our server. With the 1 copy of PineConnector EA, you may trade all symbols in your Symbol List.

1. Check Number of Instances

To verify the number of PineConnector EAs, press ALT+R (Windows) or Option+R (Mac) on your keyboard to display all open charts in MetaTrader. Examine the top corners of each chart to identify if a PineConnector EA is attached.

Scenario 1: Multiple Instances of PineConnector EA

If you see your license details on more than one chart, inspect the License ID printed on each chart. For every unique License ID, there should only be one instance of PineConnector EA.

For example, if you have only one unique License ID, you should have only one instance of PineConnector EA. If you have three unique License IDs, you should have three instances of PineConnector EA, with each ID appearing only once.

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Duplicate Instances If you have duplicate instances of the PineConnector EA for a particular License ID, proceed to Step 2.

Scenario 2: Single Instance of PineConnector EA

If you see your license details on only one chart, you’ve setup your EA correctly.

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Single Instance If you do not have duplicate instances, you do not need to proceed to Step 2. If the EA seems to be working inconsistently, please ensure the following:

2. Removing EA Instance

To remove Expert Advisors (EAs) from your MetaTrader terminal, follow the steps below:

MetaTrader 4

If you are using MetaTrader 4, right click on the chart where you’d like to remove the instance → Expert Advisors → Remove.

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MetaTrader 5

If you are using MetaTrader 5, right click on any chart → Expert List → Click on instances you’d like to remove → Remove.

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